
Simulation examples

2

Chapter overview
The examples in this chapter provide an introduction to 
the methods and tools for creating circuit designs, 
running simulations, and analyzing simulation results. 
All analyses are performed on the same example circuit to 
clearly illustrate analysis setup, simulation, and 
result-analysis procedures for each analysis type.

This chapter includes the following sections:

• Example circuit creation on page 2-58

• Performing a bias point analysis on page 2-64

• DC sweep analysis on page 2-68

• Transient analysis on page 2-74

• AC sweep analysis on page 2-79

• Parametric analysis on page 2-84

• Performance analysis on page 2-90
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Example circuit creation
This section describes how to use Orcad Capture to create 
the simple diode clipper circuit shown in Figure 2.

Figure 2 Diode clipper circuit.

To create a new PSpice project

1 From the Windows Start menu, choose the Orcad 
program folder and then the Capture shortcut to start 
Capture.

2 In the Project Manager, from the File menu, point to 
New and choose Project.

3 Select Analog or Mixed-Signal Circuit Wizard.

4 In the Name text box, enter the name of the project 
(CLIPPER).

5 Use the Browse button to select the location for the 
project files, then click OK.

6 In the Create PSpice Project dialog box, select Create a 
blank project. 

7 Click OK.
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No special libraries need to be configured at this time. 
A new page will be displayed in Capture and the new 
project will be configured in the Project Manager.

To place the voltage sources

1 In Capture, switch to the schematic page editor.

2 From the Place menu, choose Part to display the Place 
Part dialog box.

3 Add the library for the parts you need to place:

a Click the Add Library button.

b Select SOURCE.OLB (from the PSpice library) and 
click Open.

4 In the Part text box, type VDC.

5 Click OK.

6 Move the pointer to the correct position on the 
schematic page (see Figure 2) and click to place the 
first part.

7 Move the cursor and click again to place the second 
part.

8 Right-click and choose End Mode to stop placing 
parts.

To place the diodes

1 From the Place menu, choose Part to display the Place 
Part dialog box.

2 Add the library for the parts you need to place:

a Click the Add Library button.

b Select DIODE.OLB (from the PSpice library) and 
click Open.

3 In the Part text box, type D1N39 to display a list of 
diodes.

4 Select D1N3940 from the Part List and click OK.

5 Press r to rotate the diode to the correct orientation.

or press S+p

Note There are two sets of library files 
supplied with Capture and PSpice. The 
standard schematic part libraries are found 
in the directory Capture\Library. The part 
libraries that are designed for simulation 
with PSpice are found in the sub-directory 
Capture\Library\PSpice. In order to have 
access to specific parts, you must first 
configure the library in Capture using the 
Add Library function.

or press S+p

When placing parts:

• Leave space to connect the parts with 
wires.

• You will change part names and values 
that do not match those shown in 
Figure 2 later in this section.
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6 Click to place the first diode (D1), then click to place 
the second diode (D2).

7 Right-click and choose End Mode to stop placing 
parts.

To move the text associated with the diodes (or any other object)

1 Click the text to select it, then drag the text to a new 
location.

To place the other parts

1 From the Place menu, choose Part to display the Place 
Part dialog box.

2 Add the library for the parts you need to place:

a Click the Add Library button.

b Select ANALOG.OLB (from the PSpice library) 
and click Open.

3 Follow similar steps as described for the diodes to 
place the parts listed below, according to Figure 2. The 
part names you need to type in the Part name text box 
of the Place Part dialog box are shown in parentheses:

• resistors (R)

• capacitor (C)

4 To place the off-page connector parts 
(OFFPAGELEFT-R), click the Place Off-Page 
Connector button on the tool palette.

5 Add the library for the parts you need to place:

a Click the Add Library button.

b Select CAPSYM.OLB (from the Capture library) 
and click Open.

6 Place the off-page connector parts according to 
Figure 2.

7 To place the ground parts (0), click the GND button on 
the tool palette.

press S+p or
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8 Add the library for the parts you need to place:

a Click the Add Library button.

b Select SOURCE.OLB (from the PSpice library) and 
click Open.

9 Place the ‘0’ ground part from SOURCE .OLB as 
shown in Figure 2.

To connect the parts

1 From the Place menu, choose Wire to begin wiring 
parts.

The pointer changes to a crosshair.

2 Click the connection point (the very end) of the pin on 
the off-page connector at the input of the circuit.

3 Click the nearest connection point of the input resistor 
R1.

4 Connect the other end of R1 to the output capacitor.

5 Connect the diodes to each other and to the wire 
between them:

a Click the connection point of the cathode for the 
lower diode.

b Move the cursor straight up and click the wire 
between the diodes. The wire ends, and the 
junction of the wire segments becomes visible.

c Click again on the junction to continue wiring.

d Click the end of the upper diode’s anode pin.

6 Continue connecting parts until the circuit is wired as 
shown in Figure 2 on page 2-58.

To assign names (labels) to the nets

1 From the Place menu, choose Net Alias to display the 
Place Net Alias dialog box.

2 In the Name text box, type Mid.

To stop wiring, right-click and choose End 
Wire. The pointer changes to the default 
arrow.

Clicking on any valid connection point ends 
a wire. A valid connection point is shown as 
a box (see Figure 3).

If you make a mistake when placing or 
connecting components:

1 From the Edit menu, choose Undo, or 
click  .

Figure  3 Connection points.

 
or press  S+w

Pspug.book  Page 61  Tuesday, May 16, 2000  1:17 PM



Chapter 2    Simulation examples

62

3 Click OK.

4 Place the net alias on any segment of the wire that 
connects R1, R2, R3, the diodes, and the capacitor. The 
lower left corner of the net alias must touch the wire.

5 Right-click and choose End Mode to quit the Net Alias 
function.

To assign names (labels) to the off-page connectors

Label the off-page connectors as shown in Figure 2 on 
page 2-58.

1 Double-click the name of an off-page connector to 
display the Display Properties dialog box.

2 In the Name text box, type the new name.

3 Click OK.

4 Select and relocate the new name as desired.

To assign names to the parts

1 Double-click the second VDC part to display the Parts 
spreadsheet.

2 Click in the first cell under the Reference column.

3 Type in the new name Vin.

4 Click Apply to update the changes to the part, then 
close the spreadsheet.

5 Continue naming the remaining parts until your 
schematic looks like Figure 2 on page 2-58.

To change the values of the parts

1 Double-click the voltage label (0V) on V1 to display 
the Display Properties dialog box.

2 In the Value text box, type 5V.

3 Click OK.

4 Continue changing the Part Value properties of the 
parts until all the parts are defined as in Figure 2 on 
page 2-58.

A more efficient way to change the 
names, values and other properties of 
several parts in your design is to use the 
Property Editor, as follows:

1 Select all of the parts to be modified 
by pressing C and clicking each 
part.

2 From the Edit menu, choose 
Properties.

The Parts Spreadsheet appears.

Change the entries in as many of the 
cells as needed, and then click Apply to 
update all of the changes at once.
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Your schematic page should now have the same parts, 
wiring, labels, and properties as Figure 2 on page 2-58.

To save your design

1 From the File menu, choose Save.

Finding out more about setting up your design

About setting up a design for simulation

For a checklist of all of the things you need to do to set up 
your design for simulation, and how to avoid common 
problems, see Chapter 3, Preparing a design for simulation. 

press C+s or
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Running PSpice
When you perform a simulation, PSpice generates an 
output file (*.OUT). 

While PSpice is running, the progress of the simulation 
appears and is updated in the PSpice simulation output 
window (see Figure 4).

Figure 4 PSpice simulation output window.

Performing a bias point analysis

To set up a bias point analysis in Capture

1 In Capture, switch to CLIPPER.OPJ in the schematic 
page editor. 

2 From the PSpice menu, choose New Simulation 
Profile to display the New Simulation dialog box.

3 In the Name text box, type Bias.

4 From the Inherit From list, select None, then click 
Create.

The Simulation Settings dialog box appears.

5 From the Analysis type list, select Bias Point.

6 Click OK to close the Simulation Settings dialog box.

You can set up a simulation profile to run 
one analysis at a time. To run multiple 
analyses (for example, both DC sweep and 
transient analyses), set up a batch 
simulation. For more information, see 
Chapter 8, Setting up analyses 
and starting simulation.

The root schematic listed is the schematic 
page associated with the simulation profile 
you are creating.
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To simulate the circuit from within Capture

1 From the PSpice menu, choose Run.

PSpice simulates the circuit and calculates the bias 
point information.

Note Because waveform data is not calculated during a bias point 
analysis, you will not see any plots displayed in the Probe window 
for this simulation. To find out how to view the results of this 
simulation, see Using the simulation output file below.
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Using the simulation output file 
The simulation output file acts as an audit trail of the 
simulation. This file optionally echoes the contents of the 
circuit file as well as the results of the bias point 
calculation. If there are any syntax errors in the netlist 
declarations or simulation commands, or anomalies while 
performing the calculation, PSpice writes error or 
warning messages to the output file.

To view the simulation output file

1 In PSpice, from the View menu, choose Output File. 

Figure 5 shows the results of the bias point calculation 
as written in the simulation output file.

Figure 5 Simulation output file.

2 When finished, close the window.
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PSpice measures the current through a two terminal 
device into the first terminal and out of the second 
terminal. For voltage sources, current is measured from 
the positive terminal to the negative terminal; this is 
opposite to the positive current flow convention and 
results in a negative value in the output file.

Finding out more about bias point calculations

To find out more about this... See this...

bias point calculations Bias point on page 9-334
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DC sweep analysis
You can visually verify the DC response of the clipper by 
performing a DC sweep of the input voltage source and 
displaying the waveform results in the Probe window in 
PSpice. This example sets up DC sweep analysis 
parameters to sweep Vin from -10 to 15 volts in 1 volt 
increments.

Setting up and running a DC sweep analysis

To set up and run a DC sweep analysis

1 In Capture, from the PSpice menu, choose 
New Simulation Profile.

The New Simulation dialog box appears.

2 In the Name text box, type DC Sweep.

3 From the Inherit From list, select Schematic1-Bias, 
then click Create.

The Simulation Settings dialog box appears.

4 Click the Analysis tab.

5 From the Analysis type list, select DC Sweep and enter 
the values shown in Figure 6.

Note The default settings for DC Sweep 
simulation are Voltage Source as the swept 
variable type and Linear as the sweep type. 
To use a different swept variable type or 
sweep type, choose different options under 
Sweep variable and Sweep type.

Pspug.book  Page 68  Tuesday, May 16, 2000  1:17 PM



DC sweep analysis

69

Figure 6 DC sweep analysis settings.

6 Click OK to close the Simulation Settings dialog box.

7 From the File menu, choose Save.

8 From the PSpice menu, choose Run to run the analysis.
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Displaying DC analysis results
Probe windows can appear during or after the simulation 
is finished.

To plot voltages at nets In and Mid

1 From PSpice’s Trace menu, choose Add Trace.

2 In the Add Traces dialog box, select V(In) and V(Mid).

3 Click OK.

To display a trace using a marker

1 From Capture’s PSpice menu, point to Markers and 
choose Voltage Level.

2 Click to place a marker on net Out, as shown in 
Figure 8.

Figure 7 Probe window.

press I or

press C+M

Pspug.book  Page 70  Tuesday, May 16, 2000  1:17 PM



DC sweep analysis

71

Figure 8 Clipper circuit with voltage marker on net Out.

3 Right-click and choose End Mode to stop placing 
markers.

4 From the File menu, choose Save.

5 Switch to PSpice. The V(Out) waveform trace appears, 
as shown in Figure 9.

or press C+s

Figure 9 Voltage at In, Mid, and Out.
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To place cursors on V(In) and V(Mid)

1 From PSpice’s Trace menu, point to Cursor and 
choose Display.

Two cursors appear for the first trace defined in the 
legend below the x-axis—V(In) in this example. The 
Probe Cursor window also appears.

2 To display the cursor crosshairs:

a Position the mouse anywhere inside the Probe 
window.

b Click to display the crosshairs for the first cursor.

c Right-click to display the crosshairs for the second 
cursor.

In the trace legend, the part for V(In) is outlined in the 
crosshair pattern for each cursor, resulting in a dashed 
line as shown in Figure 11.

3 Place the first cursor on the V(In) waveform:

a Click the portion of the V(In) trace in the proximity 
of 4 volts on the x-axis. The cursor crosshair 
appears, and the current X and Y values for the 
first cursor appear in the cursor window.

b To fine-tune the cursor location to 4 volts on the 
x-axis, drag the crosshairs until the x-axis value of 
the A1 cursor in the cursor window is 
approximately 4.0. You can also press r and l 
for tighter control.

4 Place the second cursor on the V(Mid) waveform:

a Right-click the trace legend part (diamond) for 
V(Mid) to associate the second cursor with the Mid 
waveform. The crosshair pattern for the second 
cursor outlines the V(Mid) trace part as shown in 
Figure 12.

b Right-click the portion on the V(Mid) trace that is 
in the proximity of 4 volts on the x-axis. The X and 
Y values for the second cursor appear in the cursor 
window along with the difference (dif) between 
the two cursors’ X and Y values.

This example uses the cursors feature to 
view the numeric values for two traces and 
the difference between them by placing a 
cursor on each trace.

Table 10 Association of cursors with mouse 
buttons.

Figure  11 Trace legend with cursors 
activated.

cursor 1 left mouse button

cursor 2 right mouse button

Your ability to get as close to 4.0 as possible 
depends on screen resolution and window 
size.

Figure  12 Trace legend with V(Mid) 
symbol outlined.
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c To fine-tune the location of the second cursor to 4 
volts on the x-axis, drag the crosshairs until the 
x-axis value of the A2 cursor in the cursor window 
is approximately 4.0. You can also press V+r 
and V+l for tighter control.

Figure 13 shows the Probe window with both cursors 
placed.

Figure 13 Voltage difference at V(In) = 4 volts.

To delete all of the traces

1 From the Trace menu, choose Delete All Traces.

At this point, the design has been saved. If needed, 
you can quit Capture and PSpice and complete the 
remaining analysis exercises later using the saved 
design.

Finding out more about DC sweep analysis

To find out more about this... See this...

DC sweep analysis DC Sweep on page 9-326

There are also ways to display the 
difference between two voltages as a trace:

• In PSpice, add the trace expression 
V(In)-V(Mid).

• In Capture, from the PSpice menu, 
point to Markers and choose Voltage 
Differential. Place the two markers on 
different pins or wires.

You can also delete an individual trace by 
selecting its name in the trace legend and 
then pressing D.

Example: To delete the V(In) trace, click the 
text, V(In), located under the plot’s 
x-axis, and then press D.
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Transient analysis
This example shows how to run a transient analysis on the 
clipper circuit. This requires adding a time-domain 
voltage stimulus as shown in Figure 14.

Figure 14 Diode clipper circuit with a voltage stimulus.
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To add a time-domain voltage stimulus

1 From Capture’s PSpice menu, point to Markers and 
choose Delete All.

2 Select the ground part beneath the VIN source.

3 From the Edit menu, choose Cut.

4 Scroll down (or from the View menu, point to Zoom, 
then choose Out).

5 Place a VSTIM part (from the PSpice library 
SOURCESTM.OLB) as shown in Figure 14.

6 From the Edit menu, choose Paste.

7 Place the ground part under the VSTIM part as shown 
in Figure 14.

8 From the View menu, point to Zoom, then choose All.

9 From the File menu, choose Save to save the design.

To set up the stimulus 

1 Select the VSTIM part (V3).

2 From the Edit menu, choose PSpice Stimulus.

The New Stimulus dialog box appears.

3 In the New Stimulus dialog box, type SINE.

4 Click SIN (sinusoidal), then click OK.

5 In the SIN Attributes dialog box, set the first three 
properties as follows:

Offset Voltage = 0
Amplitude = 10
Frequency = 1kHz

6 Click Apply to view the waveform. 

The Stimulus Editor window should look like 
Figure 15.

or press C+v

If you do not have the 
Stimulus Editor
1 Place a VSIN part instead of VSTIM and 

double-click it.

2 In the Edit Part dialog box, click User 
Properties.

3 Set values for the VOFF, VAMPL, and 
FREQ properties as defined in step 5. 
When finished, click OK.
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Figure 15 Stimulus Editor window.

7 Click OK.

8 From the File menu, choose Save to save the stimulus 
information. Click Yes to update the schematic.

9 From the File menu, choose Exit to exit the Stimulus 
Editor.

To set up and run the transient analysis

1 From Capture’s PSpice menu, choose 
New Simulation Profile.

The New Simulation dialog box appears.

2 In the Name text box, type Transient.

3 From the Inherit From list, select 
Schematic1-DC Sweep, then click Create.

The Simulation Settings dialog box appears.

4 Click the Analysis tab.

5 From the Analysis list, select Time Domain (Transient) 
and enter the settings shown in Figure 16.

TSTOP = 2ms

Start saving data after = 20ns

press V+@ or

Figure  16 Transient analysis simulation 
settings.
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6 Click OK to close the Simulation Settings dialog box.

7 From the PSpice menu, choose Run to perform the 
analysis.

PSpice uses its own internal time steps for 
computation. The internal time step is adjusted 
according to the requirements of the transient analysis 
as it proceeds. PSpice saves data to the waveform data 
file for each internal time step.

To display the input sine wave and clipped wave at V(Out)

1 From PSpice’s Trace menu, choose Add Trace.

2 In the trace list, select V(In) and V(Out) by clicking 
them.

3 Click OK to display the traces.

4 From the Tools menu, choose Options to display the 
Probe Options dialog box.

5 In the Use Symbols frame, click Always if it is not 
already enabled.

6 Click OK.

Figure 17 Sinusoidal input and clipped output waveforms.

Note The internal time step is different 
from the Print Step value. Print Step 
controls how often optional text format 
data is written to the simulation output 
file (*.OUT).

or press I

These waveforms illustrate the clipping of 
the input signal.
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Finding out more about transient analysis

To find out more about this... See this...

transient analysis for analog 
and mixed-signal designs* 

*  Includes how to set up time-based stimuli using the Stimulus Editor.

Chapter 11, Transient 
analysis

transient analysis for digital 
designs*

Chapter 14, Digital 
simulation
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AC sweep analysis
The AC sweep analysis in PSpice is a linear (or small 
signal) frequency domain analysis that can be used to 
observe the frequency response of any circuit at its bias 
point.

Setting up and running an AC sweep analysis
In this example, you will set up the clipper circuit for AC 
analysis by adding an AC voltage source for a stimulus 
signal (see Figure 18) and by setting up AC sweep 
parameters.

Figure 18 Clipper circuit with AC stimulus.

To change Vin to include the AC stimulus signal

1 In Capture, open CLIPPER.OPJ.

2 Select the DC voltage source, Vin, and press D to 
remove the part from the schematic page.
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3 From the Place menu, choose Part.

4 In the Part text box, type VAC (from the PSpice library 
SOURCE.OLB) and click OK.

5 Place the AC voltage source on the schematic page, as 
shown in Figure 17.

6 Double-click the VAC part (0V) to display the Parts 
spreadsheet.

7 Change the Reference cell to Vin and change the 
ACMAG cell to 1V.

8 Click Apply to update the changes and then close the 
spreadsheet.

To set up and run the AC sweep simulation

1 From Capture’s PSpice menu, choose New Simulation 
Profile.

2 In the Name text box, enter AC Sweep, then click 
create.

The Simulation Settings dialog box appears.

3 Click the Analysis tab.

4 From the Analysis type list, select AC Sweep/Noise 
and enter the settings shown in Figure 19.

Figure 19 AC sweep and noise analysis simulation settings.

Note PSpice simulation is not 
case-sensitive, so both M and m can be used 
as “milli,” and MEG, Meg, and meg can all 
be used for “mega.” However, waveform 
analysis treats M and m as mega and milli, 
respectively.
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5 Click OK to close the Simulation Settings dialog box.

6 From the PSpice menu, choose Run to start the 
simulation.

PSpice performs the AC analysis. 

To add markers for waveform analysis

1 From Capture’s PSpice menu, point to Markers, point 
to Advanced, then choose db Magnitude of Voltage.

2 Place one Vdb marker on the Out net, then place 
another on the Mid net.

3 From the File menu, choose Save to save the design.

AC sweep analysis results
PSpice displays the dB magnitude (20log10) of the voltage 
at the marked nets, Out and Mid, in a Probe window as 
shown in Figure 20 below. VDB(Mid) has a lowpass 
response due to the diode capacitances to ground. The 
output capacitance and load resistor act as a highpass 
filter, so the overall response, illustrated by VDB(out), is a 
bandpass response. Because AC is a linear analysis and 
the input voltage was set to 1V, the output voltage is the 
same as the gain (or attenuation) of the circuit.

Note You must first define a simulation 
profile for the AC Sweep/Noise analysis 
in order to use advanced markers.
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Figure 20 dB magnitude curves for “gain” at Mid and Out.

To display a Bode plot of the output voltage, including phase

1 From Capture’s PSpice menu, point to Markers, point 
to Advanced and choose Phase of Voltage.

2 Place a Vphase marker on the output next to the Vdb 
marker. 

3 Delete the Vdb marker on Mid.

4 Switch to PSpice. 

In the Probe window, the gain and phase plots both 
appear on the same graph with the same scale.

5 Click the trace name VP(Out) to select the trace.

6 From the Edit menu, choose Cut.

7 From the Plot menu, choose Add Y Axis.

8 From the Edit menu, choose Paste. 

The Bode plot appears, as shown in Figure 21.

Note Depending upon where the Vphase 
marker was placed, the trace name may be 
different, such as VP(Cout:2), VP(R4:1), or 
VP(R4:2).

For more information on Probe windows 
and trace expressions, see Chapter 17, 
Analyzing waveforms.

press C+x or

press C+V or
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Figure 21 Bode plot of clipper’s frequency response.

Finding out more about AC sweep and 
noise analysis

To find out more about this... See this...

AC sweep analysis AC sweep analysis on 
page 10-342

noise analysis based on an 
AC sweep analysis

Noise analysis on 
page 10-351
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Parametric analysis
This example shows the effect of varying input resistance 
on the bandwidth and gain of the clipper circuit by:

• Changing the value of R1 to the expression {Rval}.

• Placing a PARAM part to declare the parameter Rval.

• Setting up and running a parametric analysis to step 
the value of R1 using Rval.

Figure 22 Clipper circuit with global parameter Rval.

This example produces multiple analysis runs, each with 
a different value of R1. After the analysis is complete, you 
can analyze curve families for the analysis runs using 
PSpice A/D.
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Setting up and running the parametric analysis

To change the value of R1 to the expression {Rval}

1 In Capture, open CLIPPER.OPJ.

2 Double-click the value (1k) of part R1 to display the 
Display Properties dialog box.

3 In the Value text box, replace 1k with {Rval}.

4 Click OK.

To add a PARAM part to declare the parameter Rval

1 From Capture’s Place menu, choose Part.

2 In the Part text box, type PARAM (from the PSpice 
library SPECIAL.OLB) , then click OK.

3 Place one PARAM part in any open area on the 
schematic page.

4 Double-click the PARAM part to display the Parts 
spreadsheet, then click New.

5 In the Property Name text box, enter Rval (no curly 
braces), then click OK.

This creates a new property for the PARAM part, as 
shown by the new column labeled Rval in the 
spreadsheet.

6 Click in the cell below the Rval column and enter 1k 
as the initial value of the parametric sweep.

7 While this cell is still selected, click Display.

8 In the Display Format frame, select Name and Value, 
then click OK.

9 Click Apply to update all the changes to the PARAM 
part.

10 Close the Parts spreadsheet.

11 Select the VP marker and press D to remove the 
marker from the schematic page. 

12 From the File menu, choose Save to save the design.

PSpice interprets text in curly braces as an 
expression that evaluates to a numerical 
value. This example uses the simplest form 
of an expression—a constant. The value of 
R1 will take on the value of the Rval 
parameter, whatever it may be.

Note For more information about using 
the Parts spreadsheet, see the Orcad 
Capture User’s Guide.

This example is only interested in the 
magnitude of the response.
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To set up and run a parametric analysis to step the value of R1 
using Rval

1 From Capture’s PSpice menu, choose 
New Simulation Profile.

The New Simulation dialog box appears.

2 In the Name text box, type Parametric.

3 From the Inherit From list, select AC Sweep, then click 
Create.

The Simulation Settings dialog box appears.

4 Click the Analysis tab.

5 Under Options, select Parametric Sweep and enter the 
settings as shown below.

Figure 23 Parametric simulation settings.

6 Click OK.

7 From the PSpice menu, choose Run to start the 
analysis.

The root schematic listed is the schematic 
page associated with the simulation profile 
you are creating.

This profile specifies that the parameter 
Rval is to be stepped from 100 to 10k 
logarithmically with a resolution of 10 
points per decade. 

The analysis is run for each value of Rval. 
Because the value of R1 is defined as 
{Rval}, the analysis is run for each value of 
R1 as it logarithmically increases from 
100Ω to 10 kΩ in 20 steps, resulting in a 
total of 21 runs.
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Analyzing waveform families 
Continuing from the example above, there are 21 analysis 
runs, each with a different value of R1. After PSpice 
completes the simulation, the Available Sections dialog 
box appears, listing all 21 runs and the Rval parameter 
value for each. You can select one or more runs to display.

To display all 21 traces

1 In the Available Sections dialog box, click OK. 

All 21 traces (the entire family of curves) for VDB(Out) 
appear in the Probe window as shown in Figure 24.

Figure 24 Small signal response as R1 is varied from 100Ω 
to 10 kΩ

2 Click the trace name to select it, then press D to 
remove the traces shown.

To select individual runs, click each one 
separately.

To see more information about the section 
that produced a specific trace, double-click 
the corresponding symbol in the legend 
below the x-axis.

You can also remove the traces by 
removing the VDB marker from your 
schematic page in Capture.
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To compare the last run to the first run

1 From the Trace menu, choose Add Trace to display the 
Add Traces dialog box.

2 In the Trace Expression text box, type the following:

Vdb(Out)@1 Vdb(Out)@21

3 Click OK.

Note The difference in gain is apparent. You can also plot the difference 
of the waveforms for runs 21 and 1, then use the search commands 
to find certain characteristics of the difference.

4 Plot the new trace by specifying a waveform 
expression:

a From the Trace menu, choose Add Trace.

b In the Trace Expression text box, type the 
following waveform expression:

Vdb(Out)@1-Vdb(OUT)@21

c Click OK.

5 Use the search commands to find the value of the 
difference trace at its maximum and at a specific 
frequency:

a From the Trace menu, point to Cursor and choose 
Display.

b Right-click then left-click the trace part (triangle) 
for Vdb(Out)@1 - Vdb(Out)@21. Make sure that 
you left-click last to make cursor 1 the active 
cursor.

c From the Trace menu, point to Cursor and choose 
Max.

d From the Trace menu, point to Cursor and choose 
Search Commands.

e In the Search Command text box, type the 
following:

search forward x value (100)

f Select 2 as the Cursor to Move option.

press I or

You can avoid some of the typing for the 
Trace Expression text box by selecting 
V(OUT) twice in the trace list and inserting 
text where appropriate in the resulting 
Trace Expression.

press I or

The search command tells PSpice to search 
for the point on the trace where the x-axis 
value is 100.
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g Click OK.

Figure 25 shows the Probe window with cursors 
placed.

Note that the Y value for cursor 2 in the cursor box is 
about 17.87. This indicates that when R1 is set to 10 kΩ, 
the small signal attenuation of the circuit at 100Hz is 
17.87dB greater than when R1 is 100Ω.

6 From the Trace menu, point to Cursor and choose 
Display to turn off the display of the cursors.

7 Delete the trace.

Finding out more about parametric analysis

To find out more about this... See this...

parametric analysis Parametric analysis on 
page 12-382

using global parameters Using global parameters and 
expressions for values on 
page 3-107

Figure 25  Small signal frequency response at 100 and 10 kΩ 
input resistance.
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Performance analysis
Performance analysis is an advanced feature in PSpice 
that you can use to compare the characteristics of a family 
of waveforms. Performance analysis uses the principle of 
search commands introduced earlier in this chapter to 
define functions that detect points on each curve in the 
family.

After you define these functions, you can apply them to a 
family of waveforms and produce traces that are a 
function of the variable that changed within the family.

This example shows how to use performance analysis to 
view the dependence of circuit characteristics on a swept 
parameter. In this case, the small signal bandwidth and 
gain of the clipper circuit are plotted against the swept 
input resistance value.

To plot bandwidth vs. Rval using the performance analysis wizard

1 In Capture, open CLIPPER.OPJ.

2 From PSpice’s Trace menu, choose Performance 
Analysis. 

The Performance Analysis dialog box appears with 
information about the currently loaded data and 
performance analysis in general.

3 Click the Wizard button.

4 Click the Next> button.

5 In the Choose a Goal Function list, click Bandwidth, 
then click the Next> button.

6 Click in the Name of Trace to search text box and type 
V(Out).

7 Click in the db level down for bandwidth calc text box 
and type 3.

8 Click the Next> button. 

The wizard displays the gain trace for the first run 
(R=100) and shows how the bandwidth is measured. 
This is done to test the goal function.

The Performance Analysis menu item is 
only available if an analysis data file is 
available. In this case, the data from 
theparametric analysis of the previous 
example should still be open.

At each step, the wizard provides 
information and guidelines.

Click , then double-click V(Out).
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9 Click the Next> button or the Finish button.

A plot of the 3dB bandwidth vs. Rval appears.

10 Change the x-axis to log scale:

a From the Plot menu, choose Axis Settings.

b Click the X Axis tab.

c Under Scale, choose Log.

d Click OK.

To plot gain vs. Rval manually

1 From the Plot menu, choose Add Y Axis.

2 From the Trace menu, choose Add to display the Add 
Traces dialog box.

3 In the Functions or Macros frame, select the Goal 
Functions list, and then click the Max(1) goal function.

4 In the Simulation Output Variables list, click V(out). 

5 In the Trace Expression text box, edit the text to be 
Max(Vdb(out)), then click OK. 

PSpice displays gain on the second y-axis vs. Rval.

Figure 26 shows the final performance analysis plot of 3dB 
bandwidth and gain in dB vs. the swept input resistance 
value.

Figure 26 Performance analysis plots of bandwidth and gain vs. 
Rval.

Double-click the x-axis.

or press I

The Trace list includes goal functions only in 
performance analysis mode when the 
x-axis variable is the swept parameter.
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Finding out more about performance analysis

To find out more about this... See this...

how to use performance 
analysis

RLC filter example on 
page 12-384
Example: Monte Carlo 
analysis of a pressure sensor 
on page 13-403

how to use search 
commands and create goal 
functions

online PSpice Help
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